Halloween sale: up to 50% off any Must-Have plugin.Halloween sale: up to 50% off Every spin of our wheel wins a coupon, until October 31. Spin the wheel

WordPress vulnerability database

Every CVE published for WordPress core, plugins and themes since January 2024: 30,513 vulnerabilities, 2,009 of them in the last 30 days. The list is updated every day from the CVE List.

Severity is the CVSS 3.1 base score. Select a band to list only those. Last updated October 26, 2026.

Showing 1–10 of 10 vulnerabilities matching your filters

Known WordPress vulnerabilities, page 1 of 1
Severity Component Vulnerability Affected versions Published CVE Source
9.8 Critical Printcart Store - Web to Print Product Designer for WooCommerce (PCDesigner) Plugin printcart-integration Arbitrary File Upload Web to Print Product Designer for WooCommerce (PCDesigner) <= 2.9.1 - Unauthenticated Arbitrary File Upload to Remote Code Execution via nbdesigner_copy_image_from_url No login needed ≤ 2.9.1 Fixed in 2.9.2 CVE-2026-93388 Wordfence
9.8 Critical WooCommerce Online Product Designer 1.7.0 Plugin Arbitrary File Upload < 2.15.0 - Unauthenticated Arbitrary File Upload No login needed 1.7.0 – < 2.15.0 Fixed in 2.15.0 CVE-2026-82187 WPScan
9.1 Critical Printcart Web to Print Product Designer for WooCommerce Plugin printcart-integration Arbitrary File Deletion Unauthenticated Arbitrary File Deletion No login needed ≤ 2.5.2 Fixed in 2.5.3 CVE-2026-9725 Wordfence
9.3 Critical Lumise Product Designer Plugin lumise SQL Injection No login needed ≤ 2.0.9 Fixed in 2.0.9 CVE-2026-25371 Patchstack
9.3 Critical MyStyle Custom Product Designer Plugin mystyle-custom-product-designer SQL Injection No login needed ≤ 3.21.1 Fixed in 3.21.2 CVE-2025-48281 Patchstack
10.0 Critical Printcart Web to Print Product Designer for WooCommerce Plugin printcart-integration Arbitrary File Upload No login needed ≤ 2.3.9 Fixed in 2.4.0 CVE-2025-47641 Patchstack
9.3 Critical Printcart Web to Print Product Designer for WooCommerce Plugin printcart-integration SQL Injection No login needed ≤ 2.4.0 Fixed in 2.4.1 CVE-2025-47640 Patchstack
9.3 Critical Neon Product Designer Plugin neon-product-designer-for-woocommerce SQL Injection Unauthenticated SQL Injection No login needed ≤ 2.2.0 CVE-2025-32565 Patchstack
9.0 Critical Fancy Product Designer Plugin fancy-product-designer Arbitrary File Upload Unauthenticated Arbitrary File Upload No login needed ≤ 6.4.3 Fixed in 6.4.4 CVE-2024-51919 Patchstack
9.3 Critical Fancy Product Designer Plugin fancy-product-designer SQL Injection Unauthenticated SQL Injection No login needed ≤ 6.4.3 Fixed in 6.4.4 CVE-2024-51818 Patchstack

About this data

Where it comes from
Each row is a record from the CVE List, published by the organization that handled the report: most often Wordfence, Patchstack or WPScan. The CVE ID links to that publisher's advisory.
What is included
CVEs published since January 1, 2024 for WordPress core, plugins and themes, premium ones included. Vulnerabilities that never received a CVE ID are not listed, and rejected CVEs are removed.
Severity
The CVSS 3.1 base score set by the publisher, or by CISA when the publisher gave none. "No login needed" means the attacker needs no account, as the publisher's text states it, or as the score assumes when the text does not say.
Affected versions
The range the publisher marked as vulnerable. When the record also names the first fixed release, it is shown under the range. Some publishers only give the last affected version; when their references show the fix, the fixed release is the first one on wordpress.org after that version. If your version is newer than every affected one, that CVE does not apply to you.
Updates
Every day, after the CVE List publishes its end-of-day changes.

This website uses cookies to enhance your browsing experience and ensure the site functions properly. By continuing to use this site, you acknowledge and accept our use of cookies.

Accept All Accept Required Only