WordPress vulnerability database
Every CVE published for WordPress core, plugins and themes since January 2024: 30,513 vulnerabilities, 2,009 of them in the last 30 days. The list is updated every day from the CVE List.
Severity is the CVSS 3.1 base score. Select a band to list only those. Last updated October 26, 2026.
Showing 1–19 of 19 vulnerabilities matching your filters
| Severity | Component | Vulnerability | Affected versions | Published | CVE | Source |
|---|---|---|---|---|---|---|
| 6.5 Medium | ThirstyAffiliates | Information Disclosure Unauthenticated Non-Public Affiliate Link Destination Disclosure and Click Statistic Injection No login needed |
< 3.12.1 Fixed in 3.12.1 |
CVE-2026-97314 |
WPScan | |
| 6.5 Medium | Affiliates Manager | Broken Access Control |
≤ 2.9.49 Fixed in 2.9.50 |
CVE-2026-57654 |
Patchstack | |
| 6.4 Medium | WP Iframe Geo Style for Amazon affiliates | Cross-Site Scripting Authenticated (Contributor+) Stored Cross-Site Scripting via 'adid' Shortcode Attribute |
≤ 1.1 |
CVE-2026-8837 |
Wordfence | |
| 5.4 Medium | ThirstyAffiliates | Cross-Site Request Forgery No login needed |
≤ 3.11.9 Fixed in 3.11.10 |
CVE-2026-25024 |
Patchstack | |
| 6.5 Medium | ThirstyAffiliates | Cross-Site Scripting |
≤ 3.11.8 Fixed in 3.11.9 |
CVE-2025-67537 |
Patchstack | |
| 4.3 Medium | SUMO Affiliates Pro | Information Disclosure Sensitive Data Exposure |
≤ 11.0.0 Fixed in 11.1.0 |
CVE-2025-64228 |
Patchstack | |
| 5.3 Medium | Coupon Affiliates | Broken Access Control No login needed |
≤ 7.2.0 Fixed in 7.2.1 |
CVE-2025-62884 |
Patchstack | |
| 4.3 Medium | Coupon Affiliates | Broken Access Control |
≤ 6.8.0 Fixed in 6.8.1 |
CVE-2025-59567 |
Patchstack | |
| 6.5 Medium | StoreEngine – Powerful WordPress eCommerce Plugin for Payments, Memberships, Affiliates, Sales & More | Path Traversal Powerful WordPress eCommerce Plugin for Payments, Memberships, Affiliates, Sales & More <= 1.5.0 - Authenticated (Subscriber+) Arbitrary File Download |
≤ 1.5.0 Fixed in 1.9.0 |
CVE-2025-9215 |
Wordfence | |
| 6.5 Medium | Coupon Affiliates | Broken Access Control Settings Change No login needed |
≤ 6.4.0 Fixed in 6.4.2 |
CVE-2025-54025 |
Patchstack | |
| 6.5 Medium | Coupon Affiliates | Cross-Site Request Forgery No login needed |
≤ 6.4.0 Fixed in 6.4.1 |
CVE-2025-54022 |
Patchstack | |
| 6.1 Medium | Coupon Affiliates – Affiliate Plugin for WooCommerce | Cross-Site Scripting Affiliate Plugin for WooCommerce <= 6.3.0 - Reflected Cross-Site Scripting via 'commission_summary' Parameter No login needed |
≤ 6.3.0 |
CVE-2025-3598 |
Wordfence | |
| 6.1 Medium | Affiliate Program Suite — SliceWP Affiliates | Cross-Site Request Forgery Cross-Site Request Forgery to Reflected Cross-Site Scripting No login needed |
≤ 1.1.23 |
CVE-2024-12454 |
Wordfence | |
| 6.5 Medium | Coupon Affiliates – Affiliate Plugin for WooCommerce | Arbitrary Shortcode Execution Affiliate Plugin for WooCommerce <= 5.16.7.1 - Unauthenticated Arbitrary Shortcode Execution and Reflected Cross-Site Scripting No login needed |
≤ 5.16.7.1 Fixed in 5.17.0 |
CVE-2024-12421 |
Wordfence | |
| 6.1 Medium | WordPress Affiliates Plugin — SliceWP Affiliates | Cross-Site Scripting Reflected Cross-Site Scripting No login needed |
≤ 1.1.20 |
CVE-2024-8714 |
Wordfence | |
| 5.9 Medium | SliceWP | Cross-Site Scripting |
≤ 1.1.10 Fixed in 1.1.11 |
CVE-2024-34413 |
Patchstack | |
| 4.3 Medium | Affiliates Manager | Cross-Site Request Forgery No login needed |
≤ 2.9.34 Fixed in 2.9.43 |
CVE-2024-0859 |
Wordfence | |
| 5.3 Medium | Affiliates Manager | Information Disclosure WordPress Affiliates Manager Plugin <= 2.9.30 is vulnerable to Sensitive Data Exposure No login needed |
≤ 2.9.30 Fixed in 2.9.31 |
CVE-2023-52148 |
Patchstack | |
| 4.3 Medium | Affiliates Manager | Cross-Site Request Forgery WordPress Affiliates Manager Plugin <= 2.9.31 is vulnerable to Cross Site Request Forgery (CSRF) No login needed |
≤ 2.9.31 Fixed in 2.9.32 |
CVE-2023-52130 |
Patchstack |
About this data
- Where it comes from
- Each row is a record from the CVE List, published by the organization that handled the report: most often Wordfence, Patchstack or WPScan. The CVE ID links to that publisher's advisory.
- What is included
- CVEs published since January 1, 2024 for WordPress core, plugins and themes, premium ones included. Vulnerabilities that never received a CVE ID are not listed, and rejected CVEs are removed.
- Severity
- The CVSS 3.1 base score set by the publisher, or by CISA when the publisher gave none. "No login needed" means the attacker needs no account, as the publisher's text states it, or as the score assumes when the text does not say.
- Affected versions
- The range the publisher marked as vulnerable. When the record also names the first fixed release, it is shown under the range. Some publishers only give the last affected version; when their references show the fix, the fixed release is the first one on wordpress.org after that version. If your version is newer than every affected one, that CVE does not apply to you.
- Updates
- Every day, after the CVE List publishes its end-of-day changes.
CVE® records are © The MITRE Corporation and used under the CVE Terms of Use. CVE is a registered trademark of The MITRE Corporation.