WordPress vulnerability database
Every CVE published for WordPress core, plugins and themes since January 2024: 30,513 vulnerabilities, 2,009 of them in the last 30 days. The list is updated every day from the CVE List.
Severity is the CVSS 3.1 base score. Select a band to list only those. Last updated October 26, 2026.
Showing 1–16 of 16 vulnerabilities matching your filters
| Severity | Component | Vulnerability | Affected versions | Published | CVE | Source |
|---|---|---|---|---|---|---|
| 6.1 Medium | Better Messages – Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss | Cross-Site Scripting Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss <= 2.10.2 - Unauthenticated Stored Cross-Site Scripting No login needed |
≤ 2.10.2 Fixed in 2.10.4 |
CVE-2025-14154 |
Wordfence | |
| 6.4 Medium | PeepSo Core: Groups | Cross-Site Scripting Authenticated (Subscriber+) Stored Cross-Site Scripting via Group Description |
≤ 6.4.6.0 |
CVE-2024-9017 |
Wordfence | |
| 5.3 Medium | PeepSo Core: File Uploads | Broken Access Control Insecure Direct Object Reference to Unauthenticated Sensitive Information Exposure via file_download No login needed |
≤ 6.4.6.0 |
CVE-2024-8988 |
Wordfence | |
| 4.8 Medium | Better Messages – Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss | Server-Side Request Forgery Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss <= 2.7.4 - Unauthenticated Limited Server-Side Request Forgery in nice_links No login needed |
≤ 2.7.4 Fixed in 2.7.23 |
CVE-2024-13697 |
Wordfence | |
| 6.4 Medium | Better Messages – Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss | Cross-Site Scripting Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss <= 2.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode |
≤ 2.6.9 |
CVE-2024-13612 |
Wordfence | |
| 6.1 Medium | Community by PeepSo – Social Network, Membership, Registration, User Profiles, Premium – Mobile App | Cross-Site Scripting Social Network, Membership, Registration, User Profiles, Premium – Mobile App <=7.0.3.0 - Reflected Cross-Site Scripting No login needed |
≤ 7.0.3.0 |
CVE-2024-11447 |
Wordfence | |
| 5.4 Medium | Community by PeepSo | Cross-Site Scripting Authenticated (Subscriber+) Stored Cross-Site Scripting |
≤ 6.4.6.1 Fixed in 6.4.6.2 |
CVE-2024-9873 |
Wordfence | |
| 5.3 Medium | Community by PeepSo – Social Network, Membership, Registration, User Profiles | Information Disclosure Social Network, Membership, Registration, User Profiles <= 6.4.6.0 - Unauthenticated Full Path Disclosure No login needed |
≤ 6.4.6.0 |
CVE-2024-7426 |
Wordfence | |
| 4.4 Medium | Community by PeepSo – Social Network, Membership, Registration, User Profiles | Cross-Site Scripting Social Network, Membership, Registration, User Profiles <= 6.4.5.0 - Authenticated (Administrator+) Stored Cross-Site Scripting via content Parameter |
≤ 6.4.5.0 |
CVE-2024-7618 |
Wordfence | |
| 4.4 Medium | Community by PeepSo – Social Network, Membership, Registration, User Profiles | Cross-Site Scripting Social Network, Membership, Registration, User Profiles <= 6.4.5.0 - Authenticated (Administrator+) Stored Cross-Site Scripting |
≤ 6.4.5.0 |
CVE-2024-7655 |
Wordfence | |
| 4.3 Medium | Community by PeepSo | Cross-Site Request Forgery No login needed |
≤ 6.3.1.1 Fixed in 6.3.1.2 |
CVE-2024-31251 |
Patchstack | |
| 5.3 Medium | Community by PeepSo | Information Disclosure Sensitive Data Exposure via Log File No login needed |
≤ 6.2.7.0 Fixed in 6.2.7.1 |
CVE-2024-25923 |
Patchstack | |
| 5.3 Medium | Community by PeepSo | Information Disclosure Server Information Disclosure No login needed |
≤ 6.0.9.0 Fixed in 6.1.0.0 |
CVE-2023-27630 |
Patchstack | |
| 6.5 Medium | Community by PeepSo – Social Network, Membership, Registration, User Profiles | Cross-Site Scripting WordPress PeepSo Core: Photos Plugin < 6.3.1.0 is vulnerable to Cross Site Scripting (XSS) |
< 6.3.1.0 Fixed in 6.3.1.0 |
CVE-2024-22158 |
Patchstack | |
| 4.3 Medium | Community by PeepSo | Cross-Site Request Forgery User Post Creation via CSRF No login needed |
< 6.3.1.2 Fixed in 6.3.1.2 |
CVE-2023-7125 |
WPScan | |
| 6.1 Medium | Community by PeepSo | Cross-Site Scripting Reflected XSS No login needed |
< 6.3.1.2 Fixed in 6.3.1.2 |
CVE-2024-0187 |
WPScan |
About this data
- Where it comes from
- Each row is a record from the CVE List, published by the organization that handled the report: most often Wordfence, Patchstack or WPScan. The CVE ID links to that publisher's advisory.
- What is included
- CVEs published since January 1, 2024 for WordPress core, plugins and themes, premium ones included. Vulnerabilities that never received a CVE ID are not listed, and rejected CVEs are removed.
- Severity
- The CVSS 3.1 base score set by the publisher, or by CISA when the publisher gave none. "No login needed" means the attacker needs no account, as the publisher's text states it, or as the score assumes when the text does not say.
- Affected versions
- The range the publisher marked as vulnerable. When the record also names the first fixed release, it is shown under the range. Some publishers only give the last affected version; when their references show the fix, the fixed release is the first one on wordpress.org after that version. If your version is newer than every affected one, that CVE does not apply to you.
- Updates
- Every day, after the CVE List publishes its end-of-day changes.
CVE® records are © The MITRE Corporation and used under the CVE Terms of Use. CVE is a registered trademark of The MITRE Corporation.